Growth-X supports both "Normal" and "Sales Navigator" LinkedIn Accounts where the default language is set to English.

System Requirements: your computer must meet the following prerequisites before you can install and use Growth-X. It's possible that Growth-X may install on other platforms or versions not listed here, however we can only guarantee support to systems that meet the minimum requirements.

For all operating systems

No matter which Operating System you're using, please disable your Screen-Saver or Sleep-Mode Settings of the computer. If the computer goes to Sleep, Growth-X pauses.

Suggested Minimum Internet Speed: 8Mbps

Windows

To use Growth-X on Windows, you'll need:

  • Windows 7, Windows 8, Windows 8.1, Windows 10 or later
  • An Intel Pentium 4 processor or later that's SSE2 capable
  • English must be your default language
  • Your Keyboard must be set to English while the campaigns are running

Mac

To use Growth-X on Mac, you'll need:

  • OS X Mavericks 10.9 or later
  • English must be your default language
  • Your Keyboard must be set to English while the campaigns are running

Chrome

To use Growth-X on either Windows or Mac, you'll need:

  • Google Chrome browser - Regular version.

Growth-X does not support Dev, Canary, or Beta releases of Google Chrome.

Did this answer your question?